Poco v1.8.1

2018-01-09にPocoのv1.8.1が出ていたので、遅ればせながらインストールしてみた。

インストールしたのはMacBook。OSは10.11.6で、Core2 Duo 2.4GHz, 8GB RAMというスペック。

Poco v1.8.1のBasic Edition(Linux,Mac用)を こちらからダウンロードし、圧縮を解凍したpoco-1.8.1を/Developer/に置く。

configureして、makeとmake installでPocoのインストール完了:

$ cd /Developer/poco-1.8.1
$ ./configure
Configured for Darwin
$ make -s
$ sudo make -s install

/usr/local/lib/ に旧バージョンのライブラリ(libPoco*.51.dylib以外)が残っていたら、それらは削除しておく。

POCO Fanaticをconfigure, makeして、走らせてみる:

$ cd /Users/admin/Desktop/poco_fanatic/trunk
$ ./configAll.sh 
$ ./buildAll.sh

特にエラーはなかったが、
0039_NotificationCenter
0042_AutoReleasePool
に未使用変数などのワーニングがあったので、修正してSubversionに上げておいた。

Leave a Comment


NOTE - You can use these HTML tags and attributes:
<a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <s> <strike> <strong>

16 − 1 =

This site uses Akismet to reduce spam. Learn how your comment data is processed.